package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?: ([a-zA-Z0-9]+))|(?: :(.+))?`)
var str = ` haaaa heu hii hoooo huuu
allo pateee :hello jhsdfhu
:allo, les potes comment va ?
a b c d e f :allo, ok !&*8? -_=% :okok`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}