$re = '/(?: ([a-zA-Z0-9]+))|(?: :(.+))?/';
$str = ' haaaa heu hii hoooo huuu
allo pateee :hello jhsdfhu
:allo, les potes comment va ?
a b c d e f :allo, ok !&*8? -_=% :okok';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);