using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?: ([a-zA-Z0-9]+))|(?: :(.+))?";
string input = @" haaaa heu hii hoooo huuu
allo pateee :hello jhsdfhu
:allo, les potes comment va ?
a b c d e f :allo, ok !&*8? -_=% :okok";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}