// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+?)\s(\d+?)\s(.+?)\s(.+?)\s(.+?)\s(.*?\.)$").unwrap();
let string = "10 10 \"u\" \"E2U+sip\" \"!(.*)!sip:5715590051@tivevrs.com:15080;transport=tcp!\" .
100 10 \"s\" \"x-eduroam:radius.tls\" \"\" _radsec._tcp.roaming.ja.net.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}