const regex = /^(\d+?)\s(\d+?)\s(.+?)\s(.+?)\s(.+?)\s(.*?\.)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+?)\\s(\\d+?)\\s(.+?)\\s(.+?)\\s(.+?)\\s(.*?\\.)$', 'gm')
const str = `10 10 "u" "E2U+sip" "!(.*)!sip:5715590051@tivevrs.com:15080;transport=tcp!" .
100 10 "s" "x-eduroam:radius.tls" "" _radsec._tcp.roaming.ja.net.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}