import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+?)\\s(\\d+?)\\s(.+?)\\s(.+?)\\s(.+?)\\s(.*?\\.)$";
final String string = "10 10 \"u\" \"E2U+sip\" \"!(.*)!sip:5715590051@tivevrs.com:15080;transport=tcp!\" .\n"
+ "100 10 \"s\" \"x-eduroam:radius.tls\" \"\" _radsec._tcp.roaming.ja.net.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}