package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+?)\s(\d+?)\s(.+?)\s(.+?)\s(.+?)\s(.*?\.)$`)
var str = `10 10 "u" "E2U+sip" "!(.*)!sip:5715590051@tivevrs.com:15080;transport=tcp!" .
100 10 "s" "x-eduroam:radius.tls" "" _radsec._tcp.roaming.ja.net.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}