# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<major>\d+)\.(?P<minor>\d+)\.(?P<patch>\d+)\.?(?P<pre_release>\d*)(?P<build>\S*)"
test_str = ("1.2.3.4-ASDF\n"
"1.2.3.2389+eiersalat\n"
"102.18.31.00064.lmao\n"
"1.0.3.1664888532357316300\n"
"1.0.3.1664888532357316300\n"
"22.6.0-old\n"
"123.456.789-o2341\n"
"123.456.788.asef\n"
"1.2.3\n"
"1.2.3.4")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.