const regex = new RegExp('(?P<major>\\d+)\\.(?P<minor>\\d+)\\.(?P<patch>\\d+)\\.?(?P<pre_release>\\d*)(?P<build>\\S*)', 'gm')
const str = `1.2.3.4-ASDF
1.2.3.2389+eiersalat
102.18.31.00064.lmao
1.0.3.1664888532357316300
1.0.3.1664888532357316300
22.6.0-old
123.456.789-o2341
123.456.788.asef
1.2.3
1.2.3.4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}