#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<major>\d+)\.(?P<minor>\d+)\.(?P<patch>\d+)\.?(?P<pre_release>\d*)(?P<build>\S*)"
Local $sString = "1.2.3.4-ASDF" & @CRLF & _
"1.2.3.2389+eiersalat" & @CRLF & _
"102.18.31.00064.lmao" & @CRLF & _
"1.0.3.1664888532357316300" & @CRLF & _
"1.0.3.1664888532357316300" & @CRLF & _
"22.6.0-old" & @CRLF & _
"123.456.789-o2341" & @CRLF & _
"123.456.788.asef" & @CRLF & _
"1.2.3" & @CRLF & _
"1.2.3.4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")