$re = '`(?P<major>\d+)\.(?P<minor>\d+)\.(?P<patch>\d+)\.?(?P<pre_release>\d*)(?P<build>\S*)`m';
$str = '1.2.3.4-ASDF
1.2.3.2389+eiersalat
102.18.31.00064.lmao
1.0.3.1664888532357316300
1.0.3.1664888532357316300
22.6.0-old
123.456.789-o2341
123.456.788.asef
1.2.3
1.2.3.4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);