const regex = /^----[- ](?:BEGIN|END) (?:([A-Z][A-Z0-9]+) )?(PRIVATE|PUBLIC) KEY[ -]----$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^----[- ](?:BEGIN|END) (?:([A-Z][A-Z0-9]+) )?(PRIVATE|PUBLIC) KEY[ -]----$', 'mg')
const str = `PKCS#1
-----BEGIN RSA PRIVATE KEY-----
-----END RSA PRIVATE KEY-----
-----BEGIN RSA PUBLIC KEY-----
-----END RSA PUBLIC KEY-----
PKCS#8
-----BEGIN PRIVATE KEY-----
-----END PRIVATE KEY-----
-----BEGIN ENCRYPTED PRIVATE KEY-----
-----END ENCRYPTED PRIVATE KEY-----
-----BEGIN PUBLIC KEY-----
-----END PUBLIC KEY-----
-----BEGIN DSA PRIVATE KEY-----
-----END DSA PRIVATE KEY-----
-----BEGIN DSA PUBLIC KEY-----
-----END DSA PUBLIC KEY-----
SSH2
---- BEGIN SSH2 PUBLIC KEY ----
---- END SSH2 PUBLIC KEY ----`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}