package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^----[- ](?:BEGIN|END) (?:([A-Z][A-Z0-9]+) )?(PRIVATE|PUBLIC) KEY[ -]----$`)
var str = `PKCS#1
-----BEGIN RSA PRIVATE KEY-----
-----END RSA PRIVATE KEY-----
-----BEGIN RSA PUBLIC KEY-----
-----END RSA PUBLIC KEY-----
PKCS#8
-----BEGIN PRIVATE KEY-----
-----END PRIVATE KEY-----
-----BEGIN ENCRYPTED PRIVATE KEY-----
-----END ENCRYPTED PRIVATE KEY-----
-----BEGIN PUBLIC KEY-----
-----END PUBLIC KEY-----
-----BEGIN DSA PRIVATE KEY-----
-----END DSA PRIVATE KEY-----
-----BEGIN DSA PUBLIC KEY-----
-----END DSA PUBLIC KEY-----
SSH2
---- BEGIN SSH2 PUBLIC KEY ----
---- END SSH2 PUBLIC KEY ----`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}