#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^----[- ](?:BEGIN|END) (?:([A-Z][A-Z0-9]+) )?(PRIVATE|PUBLIC) KEY[ -]----$"
Local $sString = "PKCS#1" & @CRLF & _
"-----BEGIN RSA PRIVATE KEY-----" & @CRLF & _
"-----END RSA PRIVATE KEY-----" & @CRLF & _
"-----BEGIN RSA PUBLIC KEY-----" & @CRLF & _
"-----END RSA PUBLIC KEY-----" & @CRLF & _
"" & @CRLF & _
"PKCS#8" & @CRLF & _
"-----BEGIN PRIVATE KEY-----" & @CRLF & _
"-----END PRIVATE KEY-----" & @CRLF & _
"-----BEGIN ENCRYPTED PRIVATE KEY-----" & @CRLF & _
"-----END ENCRYPTED PRIVATE KEY-----" & @CRLF & _
"-----BEGIN PUBLIC KEY-----" & @CRLF & _
"-----END PUBLIC KEY-----" & @CRLF & _
"" & @CRLF & _
"-----BEGIN DSA PRIVATE KEY-----" & @CRLF & _
"-----END DSA PRIVATE KEY-----" & @CRLF & _
"-----BEGIN DSA PUBLIC KEY-----" & @CRLF & _
"-----END DSA PUBLIC KEY-----" & @CRLF & _
"" & @CRLF & _
"SSH2" & @CRLF & _
"---- BEGIN SSH2 PUBLIC KEY ----" & @CRLF & _
"---- END SSH2 PUBLIC KEY ----"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")