import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^----[- ](?:BEGIN|END) (?:([A-Z][A-Z0-9]+) )?(PRIVATE|PUBLIC) KEY[ -]----$";
final String string = "PKCS#1\n"
+ "-----BEGIN RSA PRIVATE KEY-----\n"
+ "-----END RSA PRIVATE KEY-----\n"
+ "-----BEGIN RSA PUBLIC KEY-----\n"
+ "-----END RSA PUBLIC KEY-----\n\n"
+ "PKCS#8\n"
+ "-----BEGIN PRIVATE KEY-----\n"
+ "-----END PRIVATE KEY-----\n"
+ "-----BEGIN ENCRYPTED PRIVATE KEY-----\n"
+ "-----END ENCRYPTED PRIVATE KEY-----\n"
+ "-----BEGIN PUBLIC KEY-----\n"
+ "-----END PUBLIC KEY-----\n\n"
+ "-----BEGIN DSA PRIVATE KEY-----\n"
+ "-----END DSA PRIVATE KEY-----\n"
+ "-----BEGIN DSA PUBLIC KEY-----\n"
+ "-----END DSA PUBLIC KEY-----\n\n"
+ "SSH2\n"
+ "---- BEGIN SSH2 PUBLIC KEY ----\n"
+ "---- END SSH2 PUBLIC KEY ----";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}