use strict;
my $str = 'abcdefghijklmnop
';
my $regex = qr/(.{4})/p;
my $subst = '\\1.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";