package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.{4})`)
var str = `abcdefghijklmnop
`
var substitution = "\1."
fmt.Println(re.ReplaceAllString(str, substitution))
}