const regex = /(.{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.{4})', 'g')
const str = `abcdefghijklmnop
`;
const subst = `\1.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);