re = /^(?P<opcode>[a-zA-Z]+)(?P<byte_mode>\.[BbWw])?(?:\s+)(?P<operand_src>[A-Za-z0-9@\(\)]+)(?:(?:,\s*)|(?:\s+))(?P<operand_dst>[A-Za-z0-9@\(\)]+)/m
str = 'add 23(PC), 6(R11)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end