using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<opcode>[a-zA-Z]+)(?P<byte_mode>\.[BbWw])?(?:\s+)(?P<operand_src>[A-Za-z0-9@\(\)]+)(?:(?:,\s*)|(?:\s+))(?P<operand_dst>[A-Za-z0-9@\(\)]+)";
string input = @"add 23(PC), 6(R11)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}