import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<opcode>[a-zA-Z]+)(?P<byte_mode>\\.[BbWw])?(?:\\s+)(?P<operand_src>[A-Za-z0-9@\\(\\)]+)(?:(?:,\\s*)|(?:\\s+))(?P<operand_dst>[A-Za-z0-9@\\(\\)]+)";
final String string = "add 23(PC), 6(R11)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}