$re = '/^(?P<opcode>[a-zA-Z]+)(?P<byte_mode>\.[BbWw])?(?:\s+)(?P<operand_src>[A-Za-z0-9@\(\)]+)(?:(?:,\s*)|(?:\s+))(?P<operand_dst>[A-Za-z0-9@\(\)]+)/m';
$str = 'add 23(PC), 6(R11)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);