// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^\x00-\x7F]+").unwrap();
let string = "ইমোশনাল স্ট্যাটাস
মনের কথা,
কষ্টের কথা রেজেক্স ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}