using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\x00-\x7F]+";
string input = @"ইমোশনাল স্ট্যাটাস
মনের কথা,
কষ্ট ের কথা রেজেক্স ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}