# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z0-9\_]*)\:\s?([A-Za-z0-9\"\']*)"
test_str = ("classes = {\n"
" Romanian: 1,\n"
" English: 2,\n"
" French: 3,\n"
" German: 4,\n"
" Latin: 5,\n"
" Math: 6,\n"
" Physics: 7,\n"
" Chemistry: 8,\n"
" Biology: 9,\n"
" History: 10,\n"
" Geography: 11,\n"
" Social: 12,\n"
" Religion: 13,\n"
" Music: 14,\n"
" Arts: 15,\n"
" Sports: 16,\n"
" ComputerScience: 17,\n"
" IT: 18\n"
"};")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.