$re = '/([a-zA-Z0-9\_]*)\:\s?([A-Za-z0-9\"\']*)/m';
$str = 'classes = {
Romanian: 1,
English: 2,
French: 3,
German: 4,
Latin: 5,
Math: 6,
Physics: 7,
Chemistry: 8,
Biology: 9,
History: 10,
Geography: 11,
Social: 12,
Religion: 13,
Music: 14,
Arts: 15,
Sports: 16,
ComputerScience: 17,
IT: 18
};';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);