import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9\\_]*)\\:\\s?([A-Za-z0-9\\\"\\']*)";
final String string = "classes = {\n"
+ " Romanian: 1,\n"
+ " English: 2,\n"
+ " French: 3,\n"
+ " German: 4,\n"
+ " Latin: 5,\n"
+ " Math: 6,\n"
+ " Physics: 7,\n"
+ " Chemistry: 8,\n"
+ " Biology: 9,\n"
+ " History: 10,\n"
+ " Geography: 11,\n"
+ " Social: 12,\n"
+ " Religion: 13,\n"
+ " Music: 14,\n"
+ " Arts: 15,\n"
+ " Sports: 16,\n"
+ " ComputerScience: 17,\n"
+ " IT: 18\n"
+ "};";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}