const regex = /([a-zA-Z0-9\_]*)\:\s?([A-Za-z0-9\"\']*)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9\\_]*)\\:\\s?([A-Za-z0-9\\"\\\']*)', 'mg')
const str = `classes = {
Romanian: 1,
English: 2,
French: 3,
German: 4,
Latin: 5,
Math: 6,
Physics: 7,
Chemistry: 8,
Biology: 9,
History: 10,
Geography: 11,
Social: 12,
Religion: 13,
Music: 14,
Arts: 15,
Sports: 16,
ComputerScience: 17,
IT: 18
};`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}