$re = '/weather(?: me|for|in)?\s(.*)/i';
$str = 'weather in paso robles';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);