using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"weather(?: me|for|in)?\s(.*)";
string input = @"weather in paso robles";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}