package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)weather(?: me|for|in)?\s(.*)`)
var str = `weather in paso robles`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}