const regex = /weather(?: me|for|in)?\s(.*)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('weather(?: me|for|in)?\\s(.*)', 'i')
const str = `weather in paso robles`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}