import Foundation
let pattern = #"\..+[a-z]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"data212.data"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #". data"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)