using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\..+[a-z]";
string substitution = @". data";
string input = @"data212.data";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}