const regex = /\..+[a-z]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\..+[a-z]', 'g')
const str = `data212.data`;
const subst = `. data`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);