#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\..+[a-z]"
Local $sString = "data212.data"
Local $sSubst = ". data"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)