re = /(.*")(.*\/)(.*)(".*)/
str = 'this is ,y block of text with a "/path/to/some/file/file/test/me.txt" thsssdfd'
# Print the match result
str.match(re) do |match|
puts match.to_s
end