const regex = new RegExp('(.*")(.*\\/)(.*)(".*)', '')
const str = `this is ,y block of text with a "/path/to/some/file/file/test/me.txt" thsssdfd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}