package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*")(.*\/)(.*)(".*)`)
var str = `this is ,y block of text with a "/path/to/some/file/file/test/me.txt" thsssdfd`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}