$re = '/(.*")(.*\/)(.*)(".*)/';
$str = 'this is ,y block of text with a "/path/to/some/file/file/test/me.txt" thsssdfd';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);