// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^([a-zA-Z]{1,2}\d{1,2})\s*?(\d[a-zA-Z]{2})$").unwrap();
let string = "m20 5qj
BS3 1JP
bs3 1jp
m5 8wa
m205qj
Bs31JP";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}