#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([a-zA-Z]{1,2}\d{1,2})\s*?(\d[a-zA-Z]{2})$"
Local $sString = "m20 5qj" & @CRLF & _
"BS3 1JP" & @CRLF & _
"bs3 1jp" & @CRLF & _
"m5 8wa" & @CRLF & _
"m205qj" & @CRLF & _
"Bs31JP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")