use strict;
my $str = 'm20 5qj
BS3 1JP
bs3 1jp
m5 8wa
m205qj
Bs31JP';
my $regex = qr/^([a-zA-Z]{1,2}\d{1,2})\s*?(\d[a-zA-Z]{2})$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}