$re = '/^([a-zA-Z]{1,2}\d{1,2})\s*?(\d[a-zA-Z]{2})$/mi';
$str = 'm20 5qj
BS3 1JP
bs3 1jp
m5 8wa
m205qj
Bs31JP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);