# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*\/document-.*\/)\?.*"
test_str = ("http://wmgtrib00001011/onlineforms/vpn.asp?topnav?abc\n"
"http://docushare.corp.internal.citizensbank.com/dsweb/get/document-570486/?topnav\n"
"https://departments.internal.citizensbank.com/sites/commercialbanking/sitepages/conflicts%20office.aspx?topnav?cmcl?conflictsoffice\n"
"https://departments.internal.citizensbank.com/sites/commercialbanking/mt/_layouts/15/start.aspx#/marketing toolkit pages/marketing toolkit.aspx?topnav?cmcl?mkttoolkit\n"
"https://departments.internal.citizensbank.com/sites/cts/wiki_library/daas%20virtual%20desktop.aspx?topnav?daas\n"
"http://intranet.corp.internal.citizensbank.com/hp_news_iframe.asp\n"
"http://wiisrib00001317:8300/redirectpage.aspx?topnav?matchgifts\n"
"http://docushare.corp.internal.citizensbank.com/dsweb/get/document-611169/?feature?hr?mobile\n"
"https://departments.internal.citizensbank.com/sites/transformationpdo/sitepages/home.aspx?topnav\n"
"http://investor.citizensbank.com/about-us/our-company/leadership/board-of-directors.aspx?mobile\n"
"https://departments.internal.citizensbank.com/sites/commercialbanking/pc/default.aspx?topnav?cmcl?trainingdev\n"
"http://intranet.corp.internal.citizensbank.com/banners/f_l_webex_upgrade.png\n"
"http://intranet.corp.internal.citizensbank.com/iframe_default.asp\n"
"http://intranet.corp.internal.citizensbank.com/intranet/images/btn_sendusyournews_left.png\n"
"https://www4.citizensbankonline.com/?topnav\n"
"https://departments.internal.citizensbank.com/sites/cts/_layouts/15/start.aspx#/wiki_library/byod%20mobility.aspx?mobile\n"
"https://departments.internal.citizensbank.com/sites/commercialbanking/pm/default.aspx?topnav?cmcl?underwritingportfoliomgmt\n"
"http://docushare.corp.internal.citizensbank.com/dsweb/get/document-399508/internal_job_postings.xls?mobile\n"
"https://departments.internal.citizensbank.com/sites/cts/ctspilotcommunity/_layouts/15/start.aspx#/lists/mobile%20urls%20test/allitems.aspx?pageview=shared&initialtabid=ribbon.webpartpage&visibilitycontext=wsswebpartpage?mobile\n"
"https://departments.internal.citizensbank.com/sites/cts/_layouts/15/start.aspx#/wiki_library/office%20and%20common%20apps.aspx?topnav\n"
"http://docushare.corp.internal.citizensbank.com/dsweb/get/document-359801/?topnav\n"
"http://intranet.corp.internal.citizensbank.com/intranet/images/btn_sendcredoawardlime.png\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.