#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*\/document-.*\/)\?.*"
Local $sString = "http://wmgtrib00001011/onlineforms/vpn.asp?topnav?abc" & @CRLF & _
"http://docushare.corp.internal.citizensbank.com/dsweb/get/document-570486/?topnav" & @CRLF & _
"https://departments.internal.citizensbank.com/sites/commercialbanking/sitepages/conflicts%20office.aspx?topnav?cmcl?conflictsoffice" & @CRLF & _
"https://departments.internal.citizensbank.com/sites/commercialbanking/mt/_layouts/15/start.aspx#/marketing toolkit pages/marketing toolkit.aspx?topnav?cmcl?mkttoolkit" & @CRLF & _
"https://departments.internal.citizensbank.com/sites/cts/wiki_library/daas%20virtual%20desktop.aspx?topnav?daas" & @CRLF & _
"http://intranet.corp.internal.citizensbank.com/hp_news_iframe.asp" & @CRLF & _
"http://wiisrib00001317:8300/redirectpage.aspx?topnav?matchgifts" & @CRLF & _
"http://docushare.corp.internal.citizensbank.com/dsweb/get/document-611169/?feature?hr?mobile" & @CRLF & _
"https://departments.internal.citizensbank.com/sites/transformationpdo/sitepages/home.aspx?topnav" & @CRLF & _
"http://investor.citizensbank.com/about-us/our-company/leadership/board-of-directors.aspx?mobile" & @CRLF & _
"https://departments.internal.citizensbank.com/sites/commercialbanking/pc/default.aspx?topnav?cmcl?trainingdev" & @CRLF & _
"http://intranet.corp.internal.citizensbank.com/banners/f_l_webex_upgrade.png" & @CRLF & _
"http://intranet.corp.internal.citizensbank.com/iframe_default.asp" & @CRLF & _
"http://intranet.corp.internal.citizensbank.com/intranet/images/btn_sendusyournews_left.png" & @CRLF & _
"https://www4.citizensbankonline.com/?topnav" & @CRLF & _
"https://departments.internal.citizensbank.com/sites/cts/_layouts/15/start.aspx#/wiki_library/byod%20mobility.aspx?mobile" & @CRLF & _
"https://departments.internal.citizensbank.com/sites/commercialbanking/pm/default.aspx?topnav?cmcl?underwritingportfoliomgmt" & @CRLF & _
"http://docushare.corp.internal.citizensbank.com/dsweb/get/document-399508/internal_job_postings.xls?mobile" & @CRLF & _
"https://departments.internal.citizensbank.com/sites/cts/ctspilotcommunity/_layouts/15/start.aspx#/lists/mobile%20urls%20test/allitems.aspx?pageview=shared&initialtabid=ribbon.webpartpage&visibilitycontext=wsswebpartpage?mobile" & @CRLF & _
"https://departments.internal.citizensbank.com/sites/cts/_layouts/15/start.aspx#/wiki_library/office%20and%20common%20apps.aspx?topnav" & @CRLF & _
"http://docushare.corp.internal.citizensbank.com/dsweb/get/document-359801/?topnav" & @CRLF & _
"http://intranet.corp.internal.citizensbank.com/intranet/images/btn_sendcredoawardlime.png" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")