import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*\\/document-.*\\/)\\?.*";
final String string = "http://wmgtrib00001011/onlineforms/vpn.asp?topnav?abc\n"
+ "http://docushare.corp.internal.citizensbank.com/dsweb/get/document-570486/?topnav\n"
+ "https://departments.internal.citizensbank.com/sites/commercialbanking/sitepages/conflicts%20office.aspx?topnav?cmcl?conflictsoffice\n"
+ "https://departments.internal.citizensbank.com/sites/commercialbanking/mt/_layouts/15/start.aspx#/marketing toolkit pages/marketing toolkit.aspx?topnav?cmcl?mkttoolkit\n"
+ "https://departments.internal.citizensbank.com/sites/cts/wiki_library/daas%20virtual%20desktop.aspx?topnav?daas\n"
+ "http://intranet.corp.internal.citizensbank.com/hp_news_iframe.asp\n"
+ "http://wiisrib00001317:8300/redirectpage.aspx?topnav?matchgifts\n"
+ "http://docushare.corp.internal.citizensbank.com/dsweb/get/document-611169/?feature?hr?mobile\n"
+ "https://departments.internal.citizensbank.com/sites/transformationpdo/sitepages/home.aspx?topnav\n"
+ "http://investor.citizensbank.com/about-us/our-company/leadership/board-of-directors.aspx?mobile\n"
+ "https://departments.internal.citizensbank.com/sites/commercialbanking/pc/default.aspx?topnav?cmcl?trainingdev\n"
+ "http://intranet.corp.internal.citizensbank.com/banners/f_l_webex_upgrade.png\n"
+ "http://intranet.corp.internal.citizensbank.com/iframe_default.asp\n"
+ "http://intranet.corp.internal.citizensbank.com/intranet/images/btn_sendusyournews_left.png\n"
+ "https://www4.citizensbankonline.com/?topnav\n"
+ "https://departments.internal.citizensbank.com/sites/cts/_layouts/15/start.aspx#/wiki_library/byod%20mobility.aspx?mobile\n"
+ "https://departments.internal.citizensbank.com/sites/commercialbanking/pm/default.aspx?topnav?cmcl?underwritingportfoliomgmt\n"
+ "http://docushare.corp.internal.citizensbank.com/dsweb/get/document-399508/internal_job_postings.xls?mobile\n"
+ "https://departments.internal.citizensbank.com/sites/cts/ctspilotcommunity/_layouts/15/start.aspx#/lists/mobile%20urls%20test/allitems.aspx?pageview=shared&initialtabid=ribbon.webpartpage&visibilitycontext=wsswebpartpage?mobile\n"
+ "https://departments.internal.citizensbank.com/sites/cts/_layouts/15/start.aspx#/wiki_library/office%20and%20common%20apps.aspx?topnav\n"
+ "http://docushare.corp.internal.citizensbank.com/dsweb/get/document-359801/?topnav\n"
+ "http://intranet.corp.internal.citizensbank.com/intranet/images/btn_sendcredoawardlime.png\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}