use strict;
my $str = 'http://wmgtrib00001011/onlineforms/vpn.asp?topnav?abc
http://docushare.corp.internal.citizensbank.com/dsweb/get/document-570486/?topnav
https://departments.internal.citizensbank.com/sites/commercialbanking/sitepages/conflicts%20office.aspx?topnav?cmcl?conflictsoffice
https://departments.internal.citizensbank.com/sites/commercialbanking/mt/_layouts/15/start.aspx#/marketing toolkit pages/marketing toolkit.aspx?topnav?cmcl?mkttoolkit
https://departments.internal.citizensbank.com/sites/cts/wiki_library/daas%20virtual%20desktop.aspx?topnav?daas
http://intranet.corp.internal.citizensbank.com/hp_news_iframe.asp
http://wiisrib00001317:8300/redirectpage.aspx?topnav?matchgifts
http://docushare.corp.internal.citizensbank.com/dsweb/get/document-611169/?feature?hr?mobile
https://departments.internal.citizensbank.com/sites/transformationpdo/sitepages/home.aspx?topnav
http://investor.citizensbank.com/about-us/our-company/leadership/board-of-directors.aspx?mobile
https://departments.internal.citizensbank.com/sites/commercialbanking/pc/default.aspx?topnav?cmcl?trainingdev
http://intranet.corp.internal.citizensbank.com/banners/f_l_webex_upgrade.png
http://intranet.corp.internal.citizensbank.com/iframe_default.asp
http://intranet.corp.internal.citizensbank.com/intranet/images/btn_sendusyournews_left.png
https://www4.citizensbankonline.com/?topnav
https://departments.internal.citizensbank.com/sites/cts/_layouts/15/start.aspx#/wiki_library/byod%20mobility.aspx?mobile
https://departments.internal.citizensbank.com/sites/commercialbanking/pm/default.aspx?topnav?cmcl?underwritingportfoliomgmt
http://docushare.corp.internal.citizensbank.com/dsweb/get/document-399508/internal_job_postings.xls?mobile
https://departments.internal.citizensbank.com/sites/cts/ctspilotcommunity/_layouts/15/start.aspx#/lists/mobile%20urls%20test/allitems.aspx?pageview=shared&initialtabid=ribbon.webpartpage&visibilitycontext=wsswebpartpage?mobile
https://departments.internal.citizensbank.com/sites/cts/_layouts/15/start.aspx#/wiki_library/office%20and%20common%20apps.aspx?topnav
http://docushare.corp.internal.citizensbank.com/dsweb/get/document-359801/?topnav
http://intranet.corp.internal.citizensbank.com/intranet/images/btn_sendcredoawardlime.png
';
my $regex = qr/(.*\/document-.*\/)\?.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}