// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"oz(3[4-9]|[4-9][0-9]|[1-9][0-9]{2}|[12][0-9]{3}|3[0-8][0-9]{2}|39[0-7][0-9]|398[0-2])").unwrap();
let string = "oz31 oz32 oz33 oz34 oz35 oz55 oz100 oz123 oz999 oz1000 oz2000 oz3000 oz3981 oz3982 oz3983";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}