const regex = /oz(3[4-9]|[4-9][0-9]|[1-9][0-9]{2}|[12][0-9]{3}|3[0-8][0-9]{2}|39[0-7][0-9]|398[0-2])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('oz(3[4-9]|[4-9][0-9]|[1-9][0-9]{2}|[12][0-9]{3}|3[0-8][0-9]{2}|39[0-7][0-9]|398[0-2])', 'g')
const str = `oz31 oz32 oz33 oz34 oz35 oz55 oz100 oz123 oz999 oz1000 oz2000 oz3000 oz3981 oz3982 oz3983`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}